Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] Windows 2.4.6 candidate [was: 2.4.6 for perl 5.10]

From: Thomas den Braber <thomas(at)not-real.delos.nl>
Date: Wed Mar 04 2009 - 16:36:58 GMT
Peter,

I have tested your new release.
The indexing works fine but the searching with the swish Perl api make
Apache crash if used with modperl.

If using 2.4.5 with my self compiled swish-e api for Perl 5.10, it works
great and it is absolutely stable but with the new 2.4.6 release ( I made
sure that all files where updated in the Perl tree ) Apache crashed if I
do a search. Only searing for an attribute that returns all records like
"not swishtitle=0" work fine.

The error in apache is: Faulting application httpd.exe, version 2.2.8.0,
faulting module msvcrt.dll, version 7.0.3790.3959, fault address 0x0000d9de.

Did you compile it with the latest zlib from zlib.net ?

Maybe there is a conflict with the zlib1.dll that is in the apache
directory ? Although the zlib was there when using 2.4.5

I will try to compile it on my Ubunbtu with the latest zib libs and your
configure.in fix.

--

Thomas den Braber 

-----Original Message-----
From: Peter Karman <peter@peknet.com>
To: Swish-e Users Discussion List <users@lists.swish-e.org>
Date: Sat, 28 Feb 2009 12:48:14 -0600
Subject: [swish-e] Windows 2.4.6 candidate [was: 2.4.6 for perl 5.10]

> David Norris wrote on 2/27/09 8:43 AM:
> > On Thu, Feb 26, 2009 at 11:33 PM, Peter Karman <peter@peknet.com>
> wrote:
> >> Let me know if that works. I haven't yet actually tested the build
> on windows
> >> because I couldn't seem to get the dist.sh script to complete --
> likely due to
> >> my inability to install sysutils with apt-get per swishwiki.
> > 
> > Sysutils has been split into its constituent components, it seems.
> > (Makes sense, the tools in sysutils are entirely unrelated to each
> > other.)  You can install tofrodos instead.  I've updated the docs on
> > the wiki.
> > 
> 
> right you are.
> 
> I have created a Windows build of 2.4.6 with SWISH::API built for
> ActiveState
> Perl 5.10. It is here:
> 
>  http://swish-e.org/distribution/swish-e-2.4.6-win32.exe
> 
> Please, Windows users, download and test it. Once you do that and
> report back
> here, and I can make the 2.4.6 release official. It's long overdue.
> 
> One caveat: there is no HTML documentation in the Windows build, due to
> how that
> build process works now. The HTML docs on swish-e.org will be updated
> once 2.4.6
> is official, and the swish-e.2.4.6.tar.gz contains them as well.
> 
> -- 
> Peter Karman  .  http://peknet.com/  .  peter(at)not-real.peknet.com
> _______________________________________________
> Users mailing list
> Users@lists.swish-e.org
> http://lists.swish-e.org/listinfo/users


_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Wed Mar 4 11:37:01 2009