Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] using swish-e 2.4.5 with Activeperl

From: Peter Karman <peter(at)not-real.peknet.com>
Date: Tue Feb 24 2009 - 02:54:39 GMT
ayaz alavi wrote on 2/20/09 12:01 PM:
> Hello,
> Im using windows xp. i have problem in integrating Activeperl 5.10  with
> swish-e 2.4.5 on windows xp. I used msi installer for both activeperl and
> swishe. There is a perl folder in lib section of swish-e but
> swish-e.orgsays that you have to install it manually.
> Can anyone tell how to install swish-e perl distribution in Perl's library
> section.
> 
> Directly copy pasting it in Perl's library results in following error when
> using use swish::API
> 
> Can't locate loadable object for module SWISH::API in @INC (@INC contains:
> C:/Perl/site/lib C:/Perl/lib .) at F:\Apache\htdocs\search.pl line 3
> Compilation failed in require at F:\Apache\htdocs\search.pl line 3.
> BEGIN failed--compilation aborted at F:\Apache\htdocs\search.pl line 3.

I just installed ActiveState 5.10 1004 on my local XP vm, along with Swish-e
2.4.5. Looks like the Swish-e SWISH::API perl module was built against
ActiveState 5.8 and so is not binary compatible with ActiveState 5.10.

You can (a) install ActiveState 5.8 (I still run 5.8.x in production) or (b)
figure out how to build SWISH::API using ActiveState 5.10.

(a) is definitely easier.

-- 
Peter Karman  .  http://peknet.com/  .  peter(at)not-real.peknet.com
_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Mon Feb 23 21:54:56 2009