Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] 2.4.5 > Warning: document '...' has no content

From: Brad Bauer <bbauer(at)not-real.telstate.com>
Date: Thu Jul 24 2008 - 18:06:32 GMT
The server is using mod_gzip.  Wget has no problem decoding the content, nor
any browsers I have used.  If there is a problem I am unaware of it.   The
older version of the spider works fine, although perhaps it is not
requesting gzipped content.  


Brad Bauer

-----Original Message-----
From: users-bounces@lists.swish-e.org
[mailto:users-bounces@lists.swish-e.org] On Behalf Of Bill Moseley
Sent: Thursday, July 24, 2008 1:55 PM
To: Swish-e Users Discussion List
Subject: Re: [swish-e] 2.4.5 > Warning: document '...' has no content

On Thu, Jul 24, 2008 at 11:10:43AM -0400, Brad Bauer wrote:
> In spider.pl there is a line similar to $content = $response.decoded;  
> If I changed this line to $content = $response.content the content 
> showed up correctly.  There is obviously some sort of conflict between 
> the new spider.pl and our server.

All $response->content_decoded does is 1) uncompress the file if it's been
compressed (which should only happen if the spider requested
compression) and decodes whatever charset the input is into Perl.
Both of those things should be desirable.

So, could it be that you are sending the wrong encoding and then Perl is
unable to correctly decode?




--
Bill Moseley
moseley@hank.org

Unsubscribe from or help with the swish-e list: 
   http://swish-e.org/Discussion/

Help with Swish-e:
   http://swish-e.org/current/docs

_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users

_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Thu Jul 24 14:06:50 2008