Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] How do I index via HTTP when authentication is

From: Adam Douglas <ADouglas(at)not-real.venmarces.com>
Date: Thu Feb 21 2008 - 19:40:02 GMT
Hi Peter.

>the standard behaviour for browsers is to respect the secure flag set
on cookies, and only send cookies to https sites where
>the secure flag is set, and vice versa (send cookies to http sites only
if secure is off). So Bill is correct: http and https
>should be considered  'separate domains' wrt cookies. (The word
'domain' is overloaded -- think of it as a base url if that is >more
helpful.)

Okay I sorta get it, it would be based off the path as well I guess. I
only have one cookie present for blowfish.venmarces.com for the session.
There is two other cookies but that is for awstats. The session cookie
has the following properties.

Name: sid
Content: session_id_is_placed_here
Host: blowfish.venmarces.com
Path: /
Send for: Any type of connection
Expires: at end of session

>you likely need Net::SSLeay installed. IIRC, you tried that previously
and had some trouble.

Oh alright then. I was attempting to try install "Crypt::SSLeay" but
fails to install. Here is what I received at the end, as providing the
entire output is lengthy unless you want to see it. However I'll try
Net::SSLeay.

t/01-connect....ok 8/8# Looks like you failed 1 test of 8.
t/01-connect....dubious
        Test returned status 1 (wstat 256, 0x100)
DIED. FAILED test 1
        Failed 1/8 tests, 87.50% okay (less 7 skipped tests: 0 okay,
0.00%)
t/02-live.......ok 1/4# config on openbsd
# ssl OpenSSL 0.9.7 in /usr
# lib -L/usr/lib -lssl -lcrypto -lgcc
# inc -I/usr/include/openssl
# cc cc
t/02-live.......ok
        1/4 skipped: Network tests disabled
Failed Test    Stat Wstat Total Fail  Failed  List of Failed
------------------------------------------------------------------------
-------
t/01-connect.t    1   256     8    1  12.50%  1
8 subtests skipped.
Failed 1/3 test scripts, 66.67% okay. 1/24 subtests failed, 95.83% okay.
*** Error code 2

Stop in /home/adouglas/.cpan/build/Crypt-SSLeay-0.57 (line 857 of
Makefile).
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force

Best,
Adam

This message (including any attachments) is intended only for the use of the individual or entity to which it is addressed and may contain information that is non-public, proprietary,privileged, confidential, and exempt from disclosure under applicable law or may constitute as attorney work product. If you are not the intended recipient, you are hereby notified that any use, dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this communication in error, notify us immediately by telephone and
(i) destroy this message if a facsimile or (ii) delete this message
immediately if this is an electronic communication. Thank you.
_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Thu Feb 21 14:40:01 2008