Skip to main content.
home | support | download

Back to List Archive

Re: [swish-e] Custom Results Page

From: Clint <clintw(at)not-real.uyaphi.com>
Date: Wed Mar 07 2007 - 14:59:11 GMT
Hi Jason

Thanks for the reply. I've tried the suggestion below, but no luck. It 
gives me an message to check the error log.
When I remove the file, theres no error when a search is tried. I have 
replaced with my own paths, etc and ended
the block with a ;. I think I'll just try reinstalling fresh.  Any 
reason why you'd need .swishcgi.conf, when the parameters
are already mentioned in swish.cgi ?

Regards
Clint



Jason Purdy wrote:
> Sounds like you might need a .swishcgi.conf in the same directory as 
> your (sym-linked) swish.cgi.
>
> Here's what mine looks like:
>
> return {
>      title        => 'Custom title - search results',
>      swish_binary => '/usr/local/bin/swish-e',
>      swish_index  => [
>                  '/path/to/search/index.swish-e',
>                  '/path/to/search/index-oldissues.swish-e',
>                  '/path/to/search/index-dbnews.swish-e',
>              ],
>      template     => {
>              package         => 'SWISH::TemplateHTMLTemplate',
>              options         => {
>                  filename            => 'swish.tmpl',
>                  path                => '/path/to/search',
>                  die_on_bad_params   => 0,
>                  loop_context_vars   => 1,
>                  cache               => 1,
>              },
>          },
> }
>
> HTH,
>
> Jason
>
> Clint wrote:
>   
>> SWISH-E 2.4.5
>> Linux 2.6.9-42.0.8.ELsmp #1 SMP Tue Jan 23 13:01:26 EST 2007 i686 i686 
>> i386 GNU/Linux
>>
>>
>> I installed Swish-e 2.4.5 as an installation without root access and 
>> replaced the swish.tt and swish.tmpl files with the ones from a previous 
>> installation (we moved servers recently), but no matter what I do, the 
>> results page remains the standard one. If I look inside swish.cgi, 
>> situated in the cgi-bin directory, the paths for those templates are 
>> correct, but still no luck. Have I missed a step, or how does one get 
>> swish-e to use a custom results page?
>> Where would it be reading the standard format?
>> _______________________________________________
>> Users mailing list
>> Users@lists.swish-e.org
>> http://lists.swish-e.org/listinfo/users
>>     
> _______________________________________________
> Users mailing list
> Users@lists.swish-e.org
> http://lists.swish-e.org/listinfo/users
>
>   



_______________________________________________
Users mailing list
Users@lists.swish-e.org
http://lists.swish-e.org/listinfo/users
Received on Wed Mar 7 09:55:29 2007