Skip to main content.
home | support | download

Back to List Archive

Re: zLib Error on 64 bit Server

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Mon Nov 28 2005 - 13:10:10 GMT
On Mon, Nov 28, 2005 at 02:50:55AM -0800, Arndt Droullier wrote:
> Yes, the index was build on the same machine. I tried several sources
> (websites, filesystem) and curretly the files are max 50 kb. 
> I tried to enable or disable StoreDescription, PropCompressionLevel
> in the configuration file. Always with the same result.

That probably rules out possibility that it's a large property.  I
didn't look, but IIRC this problem is related to the 64 bit machine.

How large are the index files?  How many files are indexed?
Can you make it happen if indexing only a small number of files?

Can you run

    swish-e -T index_files

and generate the same error?


> 
> > For swish to read an incorrect value back would mean that either the
> > property file was corrupt or that swish somehow got confused when
> > indexing into the prop file to fetch the compressed property.
> 
> Is there a way to find out if the index wasn`t created properly?
> (This would reduce the problem to searching)

I'll try and look later today (I'm -0800) for ways to track it down.
It's a bit hard to debug without a 64bit machine handy.

-- 
Bill Moseley
moseley@hank.org

Unsubscribe from or help with the swish-e list: 
   http://swish-e.org/Discussion/

Help with Swish-e:
   http://swish-e.org/current/docs
   swish-e@sunsite.berkeley.edu
Received on Mon Nov 28 05:10:18 2005