Skip to main content.
home | support | download

Back to List Archive

Indexing not working (rename .temp)

From: S C <synapsebeta(at)not-real.yahoo.com>
Date: Sat Apr 02 2005 - 08:04:56 GMT
Hello

I'm using swish-e for over a year now with so far good
results, but recently we have moved our server to a
new location.

We have a long list of websites (over 1000) to index
and the program creates the Spider conf files
successfully.

swish-e version :: 2.2.3

But after running the command to index the same, index
and prop files are not being created. However, the
corresponding .temp files (rose_1.index.temp,
rose_6.index.temp) are being created but are not being
renamed after completion. The Debug info also doesn't
indicate any error/problem.

On renaming these manually to rose_1.index &
rose_6.index , and trying a merge, it gives gives an
error

Command ::
/var/www/html/swishe/swish-e-2.2.3/src/swish-e -M
rose_1.index rose_6.index 
/var/www/html/swishe/swish-e-2.2.3/new_rose.index

Error ::
err: Severe index error in header
.

Following is the conf file used for indexing

<<< rose_1.conf>>>
IndexDir                ./spider.pl
IndexFile               ./rose_1.index
SwishProgParameters     rose_spider_1.conf
DefaultContents         HTML2
IndexContents           TXT2 txt
StoreDescription HTML2 <body>
StoreDescription TXT2 1000
IndexComments           no
FuzzyIndexingMode       Stemming
HTMLLinksMetaName       swishdefault
IgnoreWords File:       ./english.txt
TranslateCharacters     :ascii7:
FileFilter .doc         catdoc "-s8859-1 -d8859-1
'%p'"
FileFilter .pdf         pdftotext   "'%p' -"
>>>


Basically the issue is with the individual index files
not being generated correctly.

Any help will be highly appreciated.

Thanks in advance.
Ashim 


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
Received on Sat Apr 2 00:05:00 2005