Skip to main content.
home | support | download

Back to List Archive

Error message from Swish-e at run

From: Rob de Santos AFANA <rdesantos(at)>
Date: Fri Jan 21 2005 - 23:31:19 GMT

I installed Swish 2.4.3 yesterday as mentioned in another message.  My
web site error log is recording the following error when users run
swish.cgi to do a search (the displayed results do have highlighting on
some entries and as far as the users can tell nothing is amiss):

Stemmed index needs to highlight: Can't locate
SWISH/ in @INC (@INC contains:
/usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl .) at
m line 30, <GEN0> line 34.

Here are lines 30-34 in

            eval { require SWISH::Stemmer };
            if ( $@ ) {
                warn('Stemmed index needs to highlight: ' .
            } else {

So did something not quite work when I compiled 2.4.3 or is it something
else more mundane?

I am running on the following platform:
Linux RedHat Fedora v2.6.10-1.9_FC2smp
Perl 5.8.3
Apache 1.3.33
Swish-e 2.4.3

-Rob de Santos
-Columbus, Ohio USA
Chairman of the Board,
Australian Football Association of North America (AFANA)
ph: 1-888-4AFANA1 (North America) (1-888-423-2621)
ph: 1-614-338-0002 (outside NA)  
web: <>
Contents of this message may not be posted
to the web or "blogged" without prior permission.
Received on Fri Jan 21 15:31:25 2005