Skip to main content.
home | support | download

Back to List Archive

using MetaNames

From: Nick Le Mouton <noodles(at)not-real.planetslackers.com>
Date: Wed Sep 29 2004 - 11:50:26 GMT
Hi

I've just added MetaNames to my swish-e config and added <meta
name="datasource" content="blah"> to 50,000 odd files. It indexes without
error, even the -T index_metanames shows it:

-----> METANAMES for /var/webroot/question/question.index <-----
        swishdefault : id= 1 type= 1  META_INDEX  Rank Bias=  0
       swishreccount : id= 2 type=42  META_INTERNAL META_PROP:NUMBER
           swishrank : id= 3 type=42  META_INTERNAL META_PROP:NUMBER
        swishfilenum : id= 4 type=42  META_INTERNAL META_PROP:NUMBER
         swishdbfile : id= 5 type=38  META_INTERNAL
META_PROP:STRING(case:compare) SortKeyLen: 100
        swishdocpath : id= 6 type= 6  META_PROP:STRING(case:compare)
SortKeyLen: 100  *presorted*
          swishtitle : id= 7 type=70  META_PROP:STRING(case:ignore)
SortKeyLen: 100  *presorted*
        swishdocsize : id= 8 type=10  META_PROP:NUMBER *presorted*
   swishlastmodified : id= 9 type=18  META_PROP:DATE *presorted*
          datasource : id=10 type= 1  META_INDEX  Rank Bias=  0
    swishdescription : id=11 type= 6  META_PROP:STRING(case:compare)
SortKeyLen: 100  *presorted*

But when I do a search it only brings up 15 results:

# SWISH format: 2.4.2
# Search words: datasource = en_col_2004
# Removed stopwords:
# Number of hits: 15
# Search time: 0.058 seconds
# Run time: 0.082 seconds

This seems very odd as the tag is definitely there on all files (as they're
all dynamically generated off the same template)

Can anyone give an explanation on why it would only be bringing back 15?

Thanks
Nick 
Received on Wed Sep 29 04:50:44 2004