Skip to main content.
home | support | download

Back to List Archive

Re: Fwd: autoconf problem, related to Swish-e install

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Thu Sep 23 2004 - 20:05:17 GMT
On Thu, Sep 23, 2004 at 12:26:13PM -0700, Richard Morin wrote:
> [related to thread: "No SWISH filters found"]
> 
> "Doctor, my arm hurts when I lift it like this."
> "So, don't lift your arm that way..."
> 
> If Mr. Eggert is correct, the Swish-e install is not
> using autoconf in a totally portable manner.  I can't
> say, however, whether this should be handled by a fix
> to the code or a note in the documentation.

You were building swish-e outside of the source directory.  Yes,
that's been a problem on some systems and I think I made some comment
about it in the docs.... oh there's this in the INSTALL doc:

    This example also shows building Swish-e in a ``build'' directory
    separate from where the source files are located. This is the
    recommended way to build Swish-e, but requires GNU Make. Without
    GNU Make you will likely need to build from within the source
    directory as shown in the previous example.

I tried that VPATH trick once on BSD and it still didn't work.  That
was a while back so maybe we could try again.  Maybe I'll send you two
tarballs that you can try building from outside the source tree and
tell me if the VPATH trick works.

-- 
Bill Moseley
moseley@hank.org

Unsubscribe from or help with the swish-e list: 
   http://swish-e.org/Discussion/

Help with Swish-e:
   http://swish-e.org/current/docs
   swish-e@sunsite.berkeley.edu
Received on Thu Sep 23 13:05:29 2004