Skip to main content.
home | support | download

Back to List Archive

Not sure I'm getting properties right.

From: Thomas R. Bruce <trb2(at)not-real.cornell.edu>
Date: Fri Aug 20 2004 - 17:23:27 GMT
Bill and all:

I'm getting "Unknown display property name" errors for a property that
swish-e -T INDEX_METANAMES shows in the index, eg.:

[tom@assembler etc]$ swish-e -T INDEX_METANAMES -f ../indexes/uscode01.index


-----> METANAMES for ../indexes/uscode01.index <-----
        swishdefault : id= 1 type= 1  META_INDEX  Rank Bias=  0
       swishreccount : id= 2 type=42  META_INTERNAL META_PROP:NUMBER
           swishrank : id= 3 type=42  META_INTERNAL META_PROP:NUMBER
        swishfilenum : id= 4 type=42  META_INTERNAL META_PROP:NUMBER
         swishdbfile : id= 5 type=38  META_INTERNAL
META_PROP:STRING(case:compare) SortKeyLen: 100 
        swishdocpath : id= 6 type= 6  META_PROP:STRING(case:compare)
SortKeyLen: 100  *presorted*
          swishtitle : id= 7 type=70  META_PROP:STRING(case:ignore)
SortKeyLen: 100  *presorted*
        swishdocsize : id= 8 type=10  META_PROP:NUMBER *presorted*
   swishlastmodified : id= 9 type=18  META_PROP:DATE *presorted*
             parents : id=10 type= 1  META_INDEX  Rank Bias=  0
         fragment-id : id=11 type= 1  META_INDEX  Rank Bias=  0
     production-date : id=12 type= 1  META_INDEX  Rank Bias=  0

Then

[tom@assembler etc]$ swish-e -w flag -p parents  -f
./indexes/uscode01.index
err: Unknown Display property name "parents"
.

Probably something obvious I'm doing wrong, but what?

T.

_____________________________________
Thomas R. Bruce (trb2@cornell.edu)
Director, Legal Information Institute
Cornell Law School
http://www.law.cornell.edu/
Received on Fri Aug 20 10:23:45 2004