Skip to main content.
home | support | download

Back to List Archive

Using the SwishSpiderConfig.pl file

From: Kaplan, Andrew H. <AHKAPLAN(at)not-real.PARTNERS.ORG>
Date: Wed Jun 16 2004 - 12:57:19 GMT
I am trying to index a directory using spider.pl. The directory in question is
on the same linux server that swish-e is installed upon.
There are no NFS mounts involved, hence the directory is local. The command
syntax that I want to use is

/usr/local/bin/swish-e -S prog -c swish.conf -v 3

The swish.conf file used with this approach is the following:

 <<...OLE_Obj...>> 

The problem is whenever I try to run the program I get an error message
indicating spider.pl could not find the SwishSpiderConfig.pl file. The line
being 
referenced in the error message is line 84. Where should the
SwishSpiderConfig.pl file be located in order for the spider.pl program to work,
or is it better
to simply comment out that line?

The other approach that I have tried involves a shorter swish.conf file:

 <<...OLE_Obj...>> 

The command syntax that is used here is /usr/local/bin/swish-e -c swish.conf -v
3

This approach does appear to index the pdf and doc files, but error messages
appear saying the program is substituting
embedded null characters in the pdf and doc files that I am indexing. I did a
check of the discussion lists and the issue 
has to do with the fact the files being indexed are binary. I tried adding
several lines to the swish.conf file including
IndexOnly, IndexContents and NoContents. That did not make a difference. Does
anyone have suggestions on where to
go from here?
Received on Wed Jun 16 12:57:20 2004