Skip to main content.
home | support | download

Back to List Archive

RE: Error Message: Index file error: Could not open the index fil

From: Kaplan, Andrew H. <AHKAPLAN(at)not-real.PARTNERS.ORG>
Date: Fri Jun 04 2004 - 18:23:34 GMT
Hi there --

I set the debug level to basic and reran a query. The same error message
occurred and the following 
lines appeared in the error_log file.

[Fri Jun  4 14:12:08 2004] [warn] module mod_php4.c is already added, skipping
[Fri Jun  4 14:12:08 2004] [notice] Apache/1.3.31 (Unix) PHP/4.3.7 configured --
resuming normal operations
[Fri Jun  4 14:12:08 2004] [notice] Accept mutex: sysvsem (Default: sysvsem)
[Fri Jun  4 14:13:10 2004] [error] [client 132.183.12.148] File does not exist:
/www/favicon.ico
Debug level set to: 1 [basic]
Config file '.swishcgi.conf': No such file or directory at
/usr/local/apache/cgi-bin/swish.cgi line 658.
swish.cgi: no results
Debug level set to: 1 [basic]
Config file '.swishcgi.conf': No such file or directory at
/usr/local/apache/cgi-bin/swish.cgi line 658.
swish.cgi: no results

I did a search (find command) for the swishcgi.conf file, but I did not come
across one.

-----Original Message-----
From: Bill Moseley [mailto:moseley@hank.org]
Sent: Friday, June 04, 2004 1:54 PM
To: Kaplan, Andrew H.
Cc: 'swish-e@sunsite.berkeley.edu'
Subject: Re: Error Message: Index file error: Could not open the index
fil e 'i


On Fri, Jun 04, 2004 at 01:45:54PM -0400, Kaplan, Andrew H. wrote:
> Hi there --
> 
> I have made some progress. The error message that I mentioned in my earlier
> e-mail does not appear, but now when I enter in a word to search for, the
> message
> I am getting now is "No results" even though I know the word is in the
> docuements.

1) Turn on debugging in the swish.cgi config

2) tail -f /var/log/apache/error_log # or whatever

3) note the command sent to swish and the output from swish

4) try and repeat from the command line

-- 
Bill Moseley
moseley@hank.org
Received on Fri Jun 4 11:23:37 2004