Skip to main content.
home | support | download

Back to List Archive

Re: SWISH-E C library version

From: Jonas Wolf <JOWOLF(at)not-real.uk.ibm.com>
Date: Wed May 26 2004 - 08:44:56 GMT
Thanks, at least now I know what I'm up against. I think the easier option 
is to install Perl 5.8 (although not that easy either).

Jonas



On Tue, 2004-05-25 at 12:22, Bill Moseley wrote:
> On Tue, May 25, 2004 at 04:02:07PM +0100, Jonas Wolf wrote:
> > Is there anyone involved with the Windows 
> > port who would know more about this - Dave?
> 
> For all the questions from Windows users on this list I'd expect that
> there would be someone that could answer that question.

Busy morning on the SWISH-E list.  :-)


Yes, my Windows build of SWISH::API requires a version of ActivePerl
5.8. 

Why?  5.8 has been the "latest" release for almost 2 years, and, API.dll
has to link against the libraries ActivePerl's MakeMaker specifies.  So,
I have to either provide one version, the other, or both.  And picking
the newer version was the easiest choice.


The SWISH::API source itself does not depend on any particular version
of ActivePerl, of course.  One could (not so easily) recompile SWISH-E
and link it against ActivePerl 5.6.  Although, builder beware, I've
never tried to compile anything against ActivePerl 5.6.

-- 
 David Norris
  http://www.webaugur.com/dave/
  ICQ - 412039
Received on Wed May 26 01:44:57 2004