Skip to main content.
home | support | download

Back to List Archive

Re: CORRECTION: compiling on IRIX 6.5, Solaris 2.8, Linux 2.4.20

From: Peter Karman <karman(at)>
Date: Thu Jan 29 2004 - 17:41:58 GMT
Bill Moseley waxed lyrical on 1/29/04 9:08 AM:

> Isn't it amazing how much time this stuff can take up?  

*sigh* yes. amazing. I did the IRIX stuff between 4 and 8 this morning. 
I could have been sleeping; but of course, I was lying awake trying to 
imagine how LD_RUN_PATH fits in with everything (yes, Margie, I AM a 
strange man).

Isn't there a
> port of debian for SGI Iris machines (is that what you are running?)

yep. We used to be an SGI subsidiary, and we still have our web servers 
running under IRIX (the SGI UNIX). SGI was very active (at least they 
were 4 years ago when I was working for them) in Linux development; I 
wouldn't be surprised if they had some kind of port.

But the machine in question is a compute server in use by 100s of 
people, so the chance of me installing something else is...welllll....

> Would anyone notice that the machine was running Debian?  Then you could 
> have done:
>    apt-get install swish-e
> and then take the rest of the day off.

Maybe I'll take the rest of the day off anyway. :)


PS: thanks for the helpful info on the compile options. I will try those 
out again when I am getting ready to set up my auto-builder for swish-e.

Peter Karman - Software Publications Engineer - Cray Inc
phone: 651-605-9009 -
Received on Thu Jan 29 09:41:59 2004