Skip to main content.
home | support | download

Back to List Archive

Unable to retrieve documents

From: Kaplan, Andrew H. <AHKAPLAN(at)not-real.PARTNERS.ORG>
Date: Tue Jan 06 2004 - 18:17:43 GMT
I have set up our webserver such that the swish.cgi page comes up when a person
wants to retrieve a document.
When the text is entered the results screen does appear with the appropriate
links to the documents in question. 
However, users are unable to access the documents.

The results screen does show the names of the files with their extensions, ie:
pdf, doc, etc. Immediately under
the files the word NULL appears in parentheses. The information about the file
including its modification date, 
size, and path also appears. Clicking on the file causes the error screen 

			Not Found -- The requested url was not found on this
server 
to appear.

I ran the swish-e indexer in the most verbose mode, and everything appeared to
go fine. The index.swish-e and index.swish-e.prop 
files are located in another directory that is a peer of the directory where the
documents are located. In other words, both directories share
the same parent directory.  I noticed another index.swish-e.prop file also
appears in the directory where the documents are located,
but there is no corresponding index.swish-e file there.  

The files that are being indexed are either Adobe pdf, MS-Word doc, MS-Excel
xls, and htm documents. They all have 
spaces between the words in their titles. The server itself has the catdoc,
xls2csv, and xpdf programs installed. 

What do I need to do to correct this problem? Thanks.
Received on Tue Jan 6 18:18:00 2004