Skip to main content.
home | support | download

Back to List Archive

Re: attribute value attaching to wrords

From: Dave Moreau <davidjmoreau(at)not-real.hotmail.com>
Date: Fri Nov 14 2003 - 03:06:29 GMT
Aaargh! I keep reply individually and not to the list... Let me retype my 
message...

>From: Bill Moseley <moseley@hank.org>
>Date: Thu, 13 Nov 2003 17:32:15 -0800 (PST)
>
>$ swish-e -c c -i 1.xml -v0 -T indexed_words parsed_tags
><xml> (undefined meta name - no action)
><foo> (undefined meta name - no action)
><bar> (undefined meta name - no action)
>     Adding:[1:swishdefault(1)]   'wordanother'   Pos:7  Stuct:0x1 ( FILE )
>
>Since those are undefined they are basically ignored.  I'm not sure what
>is the Correct Behavior, though.  Suggestions?

Interesting.

I think for XML attributes, it is more helpful to separate from surrounding 
information regardless of spacing based on how XML attributes are normally 
used.

For XML elements, the current way makes sense since tags could appear in the 
middle of words that should not be split.

>I'm curious.  Why are you using UndefinedXMLAttributes?

Now that you mention it, so am I. I'll ditch that and just index the 
undefined metatags.

> > D:\SWISH-E2_4\test>type t
> > IndexFile       D:\swish-e2_4\test\i
> > IndexDir        D:\swish-e2_4\test
> > UndefinedMetaTags       index
> > UndefinedXMLAttributes  index
> > IndexOnly .xml
> > IndexContents   XML2    .xml

dave

_________________________________________________________________
MSN 8 with e-mail virus protection service: 2 months FREE* 
http://join.msn.com/?page=features/virus
Received on Fri Nov 14 03:06:39 2003