Skip to main content.
home | support | download

Back to List Archive

Re: swish-e 2.4.0 seg fault followup/ resolution

From: Dave Stevens <dstevens(at)not-real.roaddog.com>
Date: Mon Nov 10 2003 - 03:55:29 GMT
There are a couple of significant issues with the current public RH9 glibc
implementation.  The one that specifically causes the swish-e issue I
experienced is due to an issue in the glibc code, which has been patched
and is available as a release candidate.  It's expected to go golden
sometime within the next week.  The issues with this are well documented,
so I won't bother the list with them.  If anyone would like any pointers
email me and I'll provide the info or elaborate on the list.   This also
explains a couple of issues I had building two other packages.

Engineers from RedHat insist that the current RC of the errata will work
as expected but given the scope of the issues I'm not willing to install
them just yet, even on a dev server.  They probably do work though I'd
recommend the same to anyone else and take it a step further by suggesting
that RH9 in the current public distribution is not yet suitable for
production use in a commercial environment.  Close, but no cigar.

The swish-e deployment I'm building is a proof of concept for a spider/
search portal project I'm pitching and the seg fault at quit won't be an
issue.  Other than that, swish-e works just fine, doing exactly what I
need for this demo.

Thanks again.  You've all done a superb job on swish-e.

Dave
Received on Mon Nov 10 04:09:11 2003