Skip to main content.
home | support | download

Back to List Archive

Re: index metanames, no return in search

From: Peter Karman <karman(at)not-real.cray.com>
Date: Thu Jul 10 2003 - 16:20:06 GMT
I recant; I had to re-index (I added all the requisite WordCharacter parameters 
to my config file). Now it works as expected. Thanks, David!

pek

Peter Karman wrote:

> Thanks. That didn't help, unfortunately. I get the same results: nada.
> 
> pek
> 
> David L Norris wrote:
> 
> 
>>On Thu, 2003-07-10 at 09:58, Peter Karman wrote:
>>
>>
>>>I'm indexing with the -S prog option. It seems to be working fine from the 
>>>indexing point of view, since the pubnumber is successfully captured from the 
>>>HTML files. However, I seem to be missing the trick when it comes to searching 
>>>on pubnumber content. I've read the documentation (several times).
>>
>>
>>You might simply need to add _-. to WordCharacters.
>>See WORDCHARS definition in swish-e/src/config.h if the below
>>WordCharacters line is scrambled in my email (and ignore the line
>>wrapping).
>>
>>
>>Try this config and see what happens:
>>
>>% cat swish-default.conf
>># include the PUBNUMBER meta value for each file
>>MetaNames PUBNUMBER
>>
>># save the PUBNUMBER in the index so its search-able
>>PropertyNames PUBNUMBER
>>
>># minimum word length
>>MinWordLimit 3
>>
>># Valid characters found in "words"
>>WordCharacters
>>_-.0123456789abcdefghijklmnopqrstuvwxyzB*B:CCCCC	CC
>>CCCCCCCCC C"C$C&C(C*C,C.C0C2C4C6C9C;C=C?
>>
>>
>>
> 
> 

-- 
Peter Karman - Software Publications Programmer - Cray Inc
phone: 651-605-9009 - mailto:karman@cray.com
Received on Thu Jul 10 16:20:14 2003