Skip to main content.
home | support | download

Back to List Archive

Some errors with e-swish and swish.cgi

From: Alejandro Acosta <Alejandro.Acosta(at)not-real.comsat.com.ve>
Date: Sun May 25 2003 - 20:10:07 GMT
Hello everyone, this is my first message to the list
  I just installed swish-e in my Linux server and it looks great, however, I
think
I am missing something in order to tune it up.
  Well, the case is that my swish.cgi script (which I renamed to search.cgi)
sometimes 
returns me the error "Service Currently Unavailable". The script works most
of the time
except when I try to search words like: Linux or SQL. When I try other
words, such as 
"chat, my name, etc" works perfect, even when I do booleans searchs.
  It sound very wear to me, but it is the true.
  However, when I try the search from my linux shell it works ok and even
tells me: 2 
files found.
  I have searched a lot in internet and there are many Service Currently
Unavailable 
errores, I tried some fixes but none of them worked.
  The Apache server log says nothing (it even gives back a 200 code)
  This is what I do from the shell:

--- cut here ---
[root@turbolinux cgi-bin]# SWISH_DEBUG=basic ./search.cgi >outfile
Debug level set to: 1
Config file '.swishcgi.conf': No such file or directory at ./search.cgi line
768.
(offline mode: enter name=value pairs on standard input)
Enter a query [all]: Linux
Enter max results to display [1]: 2
Found 2 results
--- cut here ---


I am running Turbolinux 6.5 over RS/6000


Thank you very much
Alejandro,-
Received on Sun May 25 20:10:15 2003