Skip to main content.
home | support | download

Back to List Archive

Re: no hits with soundex - addendum part 2

From: David Hoare <dh2(at)not-real.iucr.org>
Date: Tue Aug 20 2002 - 10:12:48 GMT
I seem to be having a discussion with myself ;)

I have had another thought - it this behaviour due to the fact that it is 
'soundexing' the year metaname (property)? Is this supposed to happen? If 
so is there any way around it?

Thanks for any help,

David

On Tue, 20 Aug 2002, David Hoare wrote:

> Follow up to this,
> 
> When I do the soundex search with year=(199*) it finds lots of hits where
> year is not like 199* (eg year is 2002)!
> 
> Curiouser and curiouser.
> 
> David
> 
> 
> On Tue, 20 Aug 2002, David Hoare wrote:
> 
> > Hi, I am new to swish-e and I must say I am verry impressed so far.
> > 
> > We are running SWISH-E 2.1-dev-25 on Redhat Linux 7.2
> > 
> > I have two configuration files which differ only in the switching on of 
> > UseSoundex. I have set up MetaNames "year" and "athr" which are extracted 
> > from the file path via
> > 
> > MetaNames year athr
> > PropertyNames year athr
> > ExtractPath year regex !^/.*/[a-z]/([0-9]+)/.+$!$1!
> > ExtractPath athr regex !^/.+/(authors).html$!$1!
> > 
> > 
> > When I search with the nosoundex index for this search I get lots of hits 
> > 
> > ./bin/swish-e -P ^ -f ./indexfiles/nosoundex.index -w "(smith) athr=authors  and  year=(199* or 2000 or 2001 or 2002)"
> > 
> > If I do the same search with the soundex file I get no hits 
> > 
> > ./bin/swish-e -P ^ -f ./indexfiles/soundex.index -w "(smith) athr=authors  and  year=(199* or 2000 or 2001 or 2002)"
> > 
> > However if I  specify only one year value it works -
> > 
> > ./bin/swish-e -P ^ -f ./indexfiles/soundex.index -w "(smith) athr=authors and  year=(199*)"
> > 
> > 
> > Can anyone see what I am doing wrong?
> > 
> > Thanks for any help,
> > 
> > David
> > 
> > 
> 
> 
Received on Tue Aug 20 10:16:17 2002