Skip to main content.
home | support | download

Back to List Archive

Spidering with Swish-e (newbie)

From: Keith Jackson <kjackson(at)not-real.eyemg.com>
Date: Thu Apr 18 2002 - 14:06:54 GMT
I am using swish-e for the first time and I am having trouble indexing
using HTTP.  Using the filesystem works fine.  I've tried using the
sample conf file (modifying it for my local setup) pointing to
http://www.lib.berkeley.edu/~ghill/spider.html, but that did not work.

Here are the facts:

Running:
swish-e -c ./swish.conf -S http

where swish.conf contains:
IndexDir http://web.eyemg.com/index.html
IndexFile /home/jackson/swish-e/swish.index
IndexName "Improvement index"
MetaNames first author
IndexReport 3
FollowSymLinks yes
IgnoreTotalWordCountWhenRanking yes
IgnoreLimit 50 1000
IndexComments 0
MaxDepth 5
Delay 60

results in:

Indexing Data Source: "HTTP-Crawler"
Indexing http://web.eyemg.com/index.html..
Can't open perl script "./swishspider": No such file or directory
retrieving http://web.eyemg.com/index.html (0)...
Can't open perl script "./swishspider": No such file or directory

Removing very common words...
no words removed.
Writing main index...
Computing hash table ...
Writing header ...
Writing index entries ...
Writing stopwords ...
no unique words indexed.
Writing file index...
Writing file list ...
Writing file offsets ...
Writing MetaNames ...
Writing offsets (2)...
no files indexed.
Running time: 1 minute.
Indexing done!


Obviously this did not work correctly.  Any help would be appreciated.

Thanks.

-- 


Keith Jackson
Chief Geek
Interactive Media Group
190 N. Union St
Suite 300
Akron, OH 44304
(330)434-7873
www.eyemg.com
Received on Thu Apr 18 14:08:23 2002