Skip to main content.
home | support | download

Back to List Archive

Re: Problems with spider.pl on windows 98 SE

From: Adam Edelman <aedelma(at)not-real.tulane.edu>
Date: Wed Feb 13 2002 - 16:56:13 GMT
> Could there be some issue with Windows SE?
>
> Try running just the spider:
>
>    perl prog-bin/spider.pl > out

> You might try adding a blank line in your sample document, just in case
> that's causing problems.

Thanks for the fast response!  I got pretty much the same thing as before so
I assume the spider is working.  It seems as if the parser is never being
called when it runs with swish.  Could this have to do with windows
inability to generate a SIGHUP? Thanks again.

Adam
----------
c:\SWISH-E>perl spider.pl
spider.pl: Reading parameters from 'SwishSpiderConfig.pl'

 -- Starting to spider: http://arena.internet2.edu/sample.htm --
?Testing 'test_url' user supplied function #1
'http://arena.internet2.edu:80/sample.htm'
+Passed all 1 tests for 'test_url' user supplied function
?Testing 'test_response' user supplied function #1
'http://arena.internet2.edu:8
0/sample.htm'
+Passed all 1 tests for 'test_response' user supplied function
>> +Fetched 0 Cnt: 1 http://arena.internet2.edu:80/sample.htm 200 OK
text/html 33 parent:
! Found 0 links in http://arena.internet2.edu:80/sample.htm

spider.pl: Max indexed files Reached

Summary for: http://arena.internet2.edu/sample.htm
Total Bytes: 33  (33.0/sec)
 Total Docs:  1  (1.0/sec)
Unique URLs:  1  (1.0/sec)

c:\SWISH-E>type out
Path-Name: http://arena.internet2.edu:80/sample.htm
Content-length: 33
Last-Mtime: 1013569857

<HTML>Sample document

</HTML>
Received on Wed Feb 13 16:58:30 2002