Skip to main content.
home | support | download

Back to List Archive

Re: Swish-e 2.0.5 crashes with Bus Error

From: Bill Moseley <moseley(at)not-real.hank.org>
Date: Thu Jul 12 2001 - 13:47:43 GMT
At 05:28 AM 07/12/01 -0700, Chris Blackstone wrote:
>On Mac OS X 10.0.4, if I try to index a web page that has a link to
>another page whose name contains an apostrophe, swish-e crashes with a
>"Bus Error". Is this supposed to happen, or is it a bug? I realize web
>page names shouldn't have apostrophes in them, but I work for a school
>district and have many teachers posting web pages who don't know/care
>about proper web page naming.

Hi Chris,

You are using -S http in 2.0.5.  And when indexing if a page contains a
HREF that contains a apostrophe swish crashes.  I assume that's what you
mean by "page name", or do you mean "title"?  You didn't say if it was the
indexing of that file or just the spidering of the file causing the problem.

So is it the spider or swish that's crashing?

You can run the spider directly (from where the spider is located) type:

      perl swishspider . http://www.arlington.k12.va.us/<the problem URL>

And then see what happens.  If that works, try indexing the one problem
file using -f fs to see if tha causes the problem.  Or try setting the
IndexDir to the URL of the problem file.

There's nothing with the apostrophe that should cause swish problems.  But
I don't know 2.0.5 code.  Are you using 2.0.5 because of the memory
problem?  If so I can probably get a non-recursive spider written for you
to try.


Bill Moseley
mailto:moseley@hank.org
Received on Thu Jul 12 13:51:39 2001