Skip to main content.
home | support | download

Back to List Archive

Re: no files being indexed using http,,,,,

From: <Kevin.Fay(at)not-real.CommerceQuest.com>
Date: Thu Apr 26 2001 - 16:27:34 GMT
Bill,

I have Perl installed and configured properly on my machine. I'm getting 
the same results when I try to build the http index. You mentioned 
something about LWP and some other support modules. What is LWP (and the 
support modules) and where can I download these?

Thanks,

Kevin





Bill Moseley <moseley@hank.org>
Sent by: swish-e@sunsite.berkeley.edu
04/26/01 11:46 AM
Please respond to moseley

 
        To:     Multiple recipients of list <swish-e@sunsite.berkeley.edu>
        cc: 
        Subject:        [SWISH-E] Re: no files being indexed using http,,,,,


At 08:12 AM 4/26/2001 -0700, Kevin.Fay@CommerceQuest.com wrote: 

>>>>

<excerpt>

Swish-e command being run: 


swish-e  -S http -c ../src/user.config 

</excerpt><<<<<<<<

And what's the output?

>>>>

<excerpt>

BTW. Jakarta Tomcat doesn't come with perl. It's a 100% pure JSP/Servlet 
engine. It's only for development uses. 

</excerpt><<<<<<<<

If you running Apache Tomcat I'm assuming you are running on unix.  And I
was saying it's hard to imagine a unix machine without perl.  But I
understand specialized machines (web severs, mail servers, dns, dbms)
that don't have all the utilities commonly found on a unix box.  Which is
why I was suggesting that if you are running a specialized web server
without perl, then you can use another unix machine with perl on the same
network to spider your web server.


You will need more than just perl to run the spider.  You will need LWP
and probably some other support modules.  So it may be easier to use a
different machine to do the spidering than spend the time installing
perl.



>>>>

<excerpt>




<bold>Bill Moseley <<moseley@hank.org></bold> 

Sent by: swish-e@sunsite.berkeley.edu 


04/26/01 10:54 AM 

Please respond to moseley 

 

        To:        Multiple recipients of list
<<swish-e@sunsite.berkeley.edu> 

        cc: 

        Subject:        [SWISH-E] Re: no files being indexed using
http,,,,,




At 07:45 AM 4/26/2001 -0700, Kevin.Fay@CommerceQuest.com wrote: 


>>>>


<<excerpt>


David, 



I would think the indexer would be more "error friendly" in diagnosing

this issue. I'll get perl on my web server and see what happens. 


<</excerpt><<<<<<<<<<<<<<<<


Well, it would help us if you posted exactly what swish command you are

running and its output. 



The new spider.pl in 2.1-dev has lots of debugging options, but that

wouldn't help in this case.



Hard to imagine a web server without perl. 



If you are running a web server without perl installed then is it a

dedicated web server?  If you have another machine with perl installed
on

the same network as your web server then you can run the swish indexing

from that machine, of course, and avoid installing perl.






Bill Moseley


mailto:moseley@hank.org




</excerpt><<<<<<<<






Bill Moseley

mailto:moseley@hank.org
Received on Thu Apr 26 16:56:19 2001