Skip to main content.
home | support | download

Back to List Archive

Re: Swish made my eyebrows burst into flame

From: Ron Klatchko <ron(at)not-real.ckm.ucsf.edu>
Date: Thu Nov 19 1998 - 17:07:29 GMT
Rene Ramos wrote:
> I didn't know I needed the libwww perl library installed
> on my system (a Sun Solaris 2.5).  Well, I obtained that and a few
> other undocumented necessities,

The LWP requirement not being documented is an oversite.  I'll look into
it.

But as for your comment about other "undocumented necessities," would
you care to elaborate on that?

> Can't locate auto/LWP/UserAgent/_need_proxy.al in @INC at
> /opt/LWperl/lib/LWP/UserAgent.pm line 195
> 
> Smells like an incorrect configuration parameter to me, but I can't
> locate exactly what needs to be changed.

There are not configuration parameters that that affect that.  Perhaps
you have incorrectly installed LWP.  Try this from you command line
(making the proper substitutions):

/path/to/perl /path/to/swishspider /tmp/moo http://whatever/url/

If this works (should create /tmp/moo.response, /tmp/moo.contents and
/tmp/moo.links) from the command line, then something is amiss. 
Otherwise, please double check your Perl install.

moo
----------------------------------------------------------------------
          Ron Klatchko - Manager, Advanced Technology Group           
           UCSF Library and Center for Knowledge Management           
                           ron@ckm.ucsf.edu
Received on Thu Nov 19 09:09:04 1998